Firefox 3.5 and WordPress – Cant Login

Posted by Paul Farrow - Under: Apple, Microsoft Windows, Software, Vista

Since upgrading to firefox 3.5, I couldnt login any more to my wordpress (currently 2.7) blog.  It was wierd as I couldnt login using firefox 3.5 on my apple running OS-X 10.5 and I couldnt login using firefox 3.5 on Vista.  But I could login on my clients machine running firefox 3.5 on Windows XP.

What seemed to be the problem was that in my userid / password cache I had two id’s for the site one with a capatalised first letter and one all lowercase, ie.  Admin and admin.

Now prior to firefox 3.5 this wasn’t a problem as it picked the correctly saved one.  Now since firefox 3.5 it looks like it always wants to pick the capitalised one and there seems to be no way to pick the non capitalised id’s however much you try to get it to do it.

Well all I needed to do was remove the duplicate unused id’s and it then worked.  You can do this from preferences -> security -> stored passwords, look for the ids you want to remove, highlight them and hit remove.

Once the duplicate id’s were tidied I could now login using firefox 3.5.  Guess this is a feature of firefox 3.5.